Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite PS4 has recovered
Posted about 1 year ago. Aug 11, 2016 - 16:03 EDT
Monitoring
we believe that we have corrected the issue on #Smite PS4; we are continuing to monitor the situation
Posted about 1 year ago. Aug 11, 2016 - 15:55 EDT
Identified
There is a Core Services issue on #Smite PC; please be patient as we work to recover
Posted about 1 year ago. Aug 11, 2016 - 15:42 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 1 year ago. Aug 11, 2016 - 15:29 EDT