Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved. #PaladinsPC
Posted 7 months ago. May 06, 2017 - 14:48 EDT
Update
We are currently investigating this issue. #PaladinsPC
Posted 7 months ago. May 06, 2017 - 14:41 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. May 06, 2017 - 14:35 EDT