Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart for #Paladins on #PC has been completed.
Posted 8 months ago. Mar 04, 2017 - 11:34 EST
Update
We will be performing an emergency restart of #Paladins #PC
We apologize for the inconvenience.
Posted 8 months ago. Mar 04, 2017 - 10:51 EST
Identified
We are currently aware of the ongoing match issues in #Paladins #PC we are very sorry for the inconvenience.
Posted 8 months ago. Mar 04, 2017 - 10:47 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Mar 04, 2017 - 10:17 EST
Identified
We will be pausing logins once again to address this issue.
Posted 8 months ago. Mar 04, 2017 - 10:09 EST
Monitoring
At this point Logins have resumed on #Paladins for #PC.
We are continuing to monitor the situation.
Posted 8 months ago. Mar 04, 2017 - 08:23 EST
Identified
We are currently working to resolve issues involving #Paladins on #PC
Posted 8 months ago. Mar 04, 2017 - 08:15 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Mar 04, 2017 - 08:12 EST
This incident affected: Paladins PC.