Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart of #Paladins #PC has been completed.
Posted about 2 months ago. Oct 07, 2017 - 00:24 EDT
Identified
We are performing an emergency restart for #Paladins #PC. The game will be up shortly.
Posted about 2 months ago. Oct 07, 2017 - 00:07 EDT
Monitoring
The emergency restart of #Paladins #PC has been completed. We are monitoring the results.
Posted about 2 months ago. Oct 06, 2017 - 23:41 EDT
Identified
We are performing an emergency restart of #Paladins #PC. The game will be back up shortly.
Posted about 2 months ago. Oct 06, 2017 - 23:26 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Oct 06, 2017 - 23:17 EDT
This incident affected: Paladins PC.