Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #PC has recovered; this issue has been resolved.
Posted about 1 month ago. Feb 07, 2017 - 20:12 EDT
Monitoring
We have corrected an issue with #Smite #PC; logins are enabled; continuing to monitor.
Posted about 1 month ago. Feb 07, 2017 - 19:56 EDT
Identified
We have identified an issue with #Smite #PC; logins temporarily limited; game back shortly.
Posted about 1 month ago. Feb 07, 2017 - 19:47 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 month ago. Feb 07, 2017 - 19:43 EDT
This incident affected: Smite PC - North America / Europe.