Paladins PC Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 15, 2018 - 10:50 EDT
Monitoring
The restart has been completed and Logins have been re-enabled.
Posted Jul 15, 2018 - 10:37 EDT
Update
We are performing an emergency restart on #Paladins #PC
Posted Jul 15, 2018 - 10:27 EDT
Investigating
We are currently investigating the issue affecting queues and logins.
Posted Jul 15, 2018 - 10:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 15, 2018 - 07:39 EDT
This incident affected: Paladins (Paladins PC).