Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Very brief connectivity issue; momentarily impacted logins; recovered normally.
Posted over 1 year ago. Mar 11, 2016 - 14:31 EST
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted over 1 year ago. Mar 11, 2016 - 14:23 EST