Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE XBox has been restored to operational; apologies for the inconvenience.
Posted about 1 month ago. Feb 19, 2017 - 15:33 EDT
Monitoring
#SMITE XBox restart is complete; logins have resumed; we are continuing to monitor.
Posted about 1 month ago. Feb 19, 2017 - 15:14 EDT
Update
we are still working to restart #SMITE XBox; game should be back shortly
Posted about 1 month ago. Feb 19, 2017 - 14:53 EDT
Identified
#SMITE XBox will be going down for an emergency restart; game back shortly
Posted about 1 month ago. Feb 19, 2017 - 14:35 EDT
Update
we are experiencing an issue with #SMITE XBox; we are currently investigating
Posted about 1 month ago. Feb 19, 2017 - 14:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 month ago. Feb 19, 2017 - 14:02 EDT
This incident affected: Smite Xbox - North America / Europe.