Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved. #paladins
Posted 11 months ago. Jan 08, 2017 - 15:07 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 11 months ago. Jan 08, 2017 - 14:42 EST
This incident affected: Paladins PC.