Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 12, 2016 - 08:59 EDT
Identified
We will be performing an emergency restart of #Smite on #Xbox.
Downtime will be minimal.
Sorry for the inconvenience.
Posted about 1 year ago. Jul 12, 2016 - 08:26 EDT