Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue has been resolved. We apologize for any inconvenience.
Posted about 2 months ago. Feb 03, 2017 - 17:11 EDT
Monitoring
Issues has been isolated , we are currently monitoring.
Posted about 2 months ago. Feb 03, 2017 - 16:52 EDT
Update
We will be pausing logins temporarily to fix issues affecting match making.
Posted about 2 months ago. Feb 03, 2017 - 16:34 EDT
Identified
We are investigating possible issue with paladins match making. #Paladins
Posted about 2 months ago. Feb 03, 2017 - 16:31 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Feb 03, 2017 - 16:29 EDT
This incident affected: Paladins PC.