Smite PC problem
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 25, 2015 - 03:04 EDT
Investigating
We are currently investigating this issue.
Posted almost 2 years ago. Sep 25, 2015 - 02:50 EDT