Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 01, 2017 - 20:00 EDT
Identified
We will be performing an emergency restart of #Smite on #PC
Posted about 2 months ago. Feb 01, 2017 - 19:29 EDT
This incident affected: Smite PC - North America / Europe.