Smite Console Temporarily Limiting Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #Xbox and #PS4 has been resolved.
Posted 5 months ago. Feb 09, 2018 - 17:35 EST
Monitoring
Logins have resumed for #Smite #Xbox and #PS4. We are monitoring the results.
Posted 5 months ago. Feb 09, 2018 - 17:08 EST
Identified
We are temporarily limiting logins for #Smite #Xbox and #PS4 to address an issue.
Posted 5 months ago. Feb 09, 2018 - 16:50 EST
This incident affected: Smite (Smite PS4, Smite Xbox).