Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. May 18, 2016 - 21:09 EDT
Update
#hirezstudios suffered a massive connectivity issue that impacted all products ( #Smite #Paladins #Tribes ); connectivity has been restored and all products are returning to normal.
Posted about 1 year ago. May 18, 2016 - 21:09 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. May 18, 2016 - 20:38 EDT