Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 01, 2016 - 16:44 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Nov 01, 2016 - 16:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 10 months ago. Nov 01, 2016 - 16:38 EDT