Divine Knockout Live Service Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 00:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2024 - 22:01 EDT
Investigating
We are currently investigating this issue.
Posted Apr 03, 2024 - 20:29 EDT
This incident affected: Divine Knockout (Divine Knockout Steam, Divine Knockout PS4, Divine Knockout Xbox, Divine Knockout Epic).