Rogue Company Live Service Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 00:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2024 - 22:02 EDT
Investigating
We are currently investigating this issue.
Posted Apr 03, 2024 - 20:28 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).