Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 13, 2018 - 13:26 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Feb 13, 2018 - 13:23 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 6 months ago. Feb 13, 2018 - 13:12 EST