Realm Royal Limiting Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed for Realms Royale
Posted 4 months ago. Jun 09, 2018 - 16:37 EDT
Investigating
We are limiting logins for Realm Royal for a moment.
Posted 4 months ago. Jun 09, 2018 - 16:27 EDT
This incident affected: Realm Royale (Realm Royale PC).