Smite Emergency Restart

Incident Report for Hi-Rez Studios, Inc

Resolved

This incident has been resolved.
Posted Jan 29, 2025 - 07:38 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2025 - 07:22 EST

Investigating

We are currently investigating this issue.
Posted Jan 29, 2025 - 06:54 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).