Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 11, 2018 - 20:52 EDT
Monitoring
Restart is complete. We will continue to monitor for any further issues.
Posted 2 months ago. Aug 11, 2018 - 19:43 EDT
Identified
We will performing another restart. The game will be back shortly.
Posted 2 months ago. Aug 11, 2018 - 19:35 EDT
Monitoring
Emergency restart is complete. We will be monitoring the results.
Posted 2 months ago. Aug 11, 2018 - 19:06 EDT
Identified
We will be performing an emergency restart on #SMITE #XBOX to address an issue with the game services. The game will be back online shortly.
Posted 2 months ago. Aug 11, 2018 - 18:56 EDT
This incident affected: Smite (Smite Xbox).