Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The restart is complete and servers are back up.
Posted 8 months ago. Feb 10, 2018 - 17:18 EST
Identified
We are performing a restart for #Paladins #PC.
Posted 8 months ago. Feb 10, 2018 - 16:56 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Feb 10, 2018 - 16:49 EST
This incident affected: Paladins (Paladins PC).