Smite/Paladins/Realm XBOX Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 23:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 09, 2024 - 13:27 EDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2024 - 13:15 EDT
This incident affected: SMITE (SMITE Xbox), Paladins (Paladins Xbox), and Realm Royale Reforged (Realm Royale Xbox).